HomeBlack Hole OrganizerPrinter Friendly Version

Black Hole Organizer

Everything you need to install, administer, and use the Black Hole Organizer Software product

1. Introduction

1.1. Introduction

Black Hole Organizer

Introduction

"black hole" (noun) (1968) : a hypothetical celestial object with a small diameter and intense gravitational field so strong that even light cannot escape from it which is believed to be created in the collapse of a very massive star" -- Webster's Collegiate Dictionary

A "black hole" is believed to pull everything into itself. Dust, cosmic debris, planets, even stars. Everything goes in, but nothing escapes. Not even light. Our definition of a Black Hole is the typical desk, with notes everywhere but you can't find anything! Like its namesake, The Black Hole Organizer will take in all of your data. Unlike the "celestial object", however, it will let you retrieve your information quickly and easily! No more shuffling papers all over your desk to find that important reminder or phone number!

Overview

Black Hole Organizer was designed to make saving and retrieving your information faster and easier. Many database and "note" programs make it difficult to get information in and out. Many of these programs reside in the taskbar or the tray, which means you have to open them up before you can enter any data. "Post-It" type notes can clutter your desktop. Other programs make you open them, use them, and close them again -- wasting time and slowing you down. The Black Hole Organizer solves these problems.

Black Hole Organizer lets you create all of the meaningful categories and sub-categories you need (like folders and subfolders on your hard drive). Sample templates are provided, for example, names and addresses. Of course, you can also create your own templates, and modify our templates to meet your needs. This saves you duplication effort and time. The program lets you set different reminder dates for every document. When your reminder date occurs, Black Hole Organizer automatically alerts you with your document.

Black Hole Organizer automatically recognizes email addresses and Web page URL's, so it's great for use on the Internet. It will let you copy text from the clipboard and quickly save it to a new document. You can drag files and drop them on the 'black hole" and instantly create a new document in a folder you specify. You can create links to files on your computer, import and export files, import and export complete categories, and more. The Black Hole Organizer also has powerful search capabilities so you can find your data FAST. It does all this and much more!

1.2. Quick Start Guide

Quick Start Guide

The document manager consists of 3 areas: Category, Document List, and the Document.

Categories
Black Hole Organizer allows you to create a structure that fits your needs. You can create any number of parent categories as well as any number of child categories. Child categories may also be referred to as sub-categories and parent categories may be referred to as root or main. To work in a given category you must select it with either your mouse or keyboard so that it is highlighted.

Document List
On the right is the list of documents contained in the selected category. You can sort these in any order. Add fields, or columns, to help you organize your documents if you wish as well.

Document
The bottom window is the selected document. If you select more than one document it will be empty. By selecting a document you will load it from the database and into the editor. The document editor is a full featured tool that will allow you to create tables and format paragraphs and text with ease.

As you get proficient with Black Hole Organizer you will learn that you can merge documents, create links to other BHO documents, search for text in documents and much more!

1.3. Portable Edition

Portable Edition

Black Hole Organizer can run on your thumb drive too so you'll have your data no matter where you roam.

Run the program. Click on Tools then click General Options.


This will open the General Options window. Click on the Actions tab. 
Check the box for Portable Edition.

Then click OK.

The data doesn't have to reside under the program's install directory, you can specify another folder area to save your data to.

The data and the program must reside on the same drive for this to work, otherwise the option is disabled.

2. Installation

2.1. Where to Obtain Software

You can download this software from our web site:

http://www.starresoft.com/bhodownload.htm

2.2. How do I download and install the software?

Instructions to download and install this software.

STEP ONE: Download Black Hole Organizer

Black Hole Organizer is distributed in a self-extracting executable file. You can download this software from our web site at http://www.starresoft.com/bhodownload.htm
You don't need any external programs to install and setup Black Hole Organizer on your PC, just follow the instructions below.

In these instructions we assume you are using Windows XP, NT, Vista or Windows 7.

Once you arrive at the site listed above, you will click the download button. After you do this:

With Internet Explorer, a dialog box will appear asking you to either Run, Save or Cancel.

If using Firefox, it will ask to Save or Cancel.

The best option is to save the file. Then it may ask where to save the file. The default that pops up is the best and safest option. Then select Save.

STEP TWO: Install Black Hole Organizer

Once you have downloaded Black Hole Organizer software, you are ready to install it. After the download is finished, the dialog box will say Download Complete. From here you will select Run (Internet Explorer) or Double Click the downloaded file (Firefox).

This will open up the installation dialog box. Just follow the instructions. During the installation, you will be prompted to accept the license agreement, along with other information needed to perform the installation. When the program is finished installing, and you are running Windows XP or earlier, you will be prompted to run the software. If you are running Windows Vista or Windows 7, the installation program will close and you will be finished with the install.

You are ready to run the software. An Icon should have been placed on your desktop. Simply double click and the software will run.

2.3. Installing Software

All you need to do is to run the file you downloaded. To do this, you can either dbl-click on it, or run it. This will run the installation program. During the installation program, you will be prompted to accept the license agreement, along with other information needed to perform the installation. When the program is finished installing, and you are running Windows XP or earlier, you will be prompted to run the software. If you are running Windows Vista or Windows 7, the installation program will close and you will be finished with the install.

2.4. When I download the software, it states that the file is corrupt. What do I do?

You need to delete the file you downloaded. Then be sure to clear the temporary files in your browser. Then try re-downloading. It should download fine and install.

If you do not know how to delete your temporary files, here are the instructions for deleting them from Internet Explorer and Firefox browsers.

Internet Explorer:
Run the program. Click on the Tools menu, then Internet Options. This will display the Options screen. Click on the Delete button listed under Browsing History. Then Click on the Delete File button listed under Temporary Internet Files. Then Click on Yes when prompted. Then Click Close, then OK. This will delete your temporary files from the system.

Firefox:
Run the program. At the top of the Firefox window, Click on the Tools menu, and Select Clear Private Data...The Clear Private Data window will open, allowing your to select which private data you want to clear. Check mark the data you want to clear, then click on Clear Private Data Now to clear the data; or click on Cancel to close the Clear Private Data window without clearing any private data.

Chrome:
Run the program. On the upper right corner of the screen, click on the Wrench. Then highlight Tools then click Clear browsing data... This will open up another browser and you will be prompted to select what you want to clear. Check mark the box "Empty the cache" and any other data you may wish to clear. Now click Clear browser data. If you change your mind, click Cancel.

2.5. Running the Software

After you have successfully installed the software onto your computer, you are ready to run the software for the first time.

If you installed this software onto a computer that is running Microsoft Windows XP or earlier, you would have been prompted to run the software after the installation process. If running Microsoft Vista or Windows 7,8, it does not run the software after the install.

To run the software, you have two options. If a shortcut was placed onto your desktop, you can run the software by dbl-clicking on the icon called Black Hole Organizer.

If a shortcut was not installed, or if you do not want to run it from the shortcut, you can run it via the Windows program menu. Click on the Start Button (XP) or the Vista Start button (Vista) or the Windows Start Orb (Windows 7) which is located at the bottom left corner of the desktop screen. This will activate the Program menu system. Then you need to click on All Programs, then Black Hole Organizer folder, then click Black Hole Organizer.

This will launch the software.

2.6. Is There an Uninstall Feature

Yes. Click on the Windows Start button, then All Programs, then Black Hole Organizer folder, then Utilities, then click Uninstall.

You will be presented with prompts requiring your permission to uninstall. Simply follow the insructions to continue.

This will un-install the software from your computer.

3. Setup

3.1. Initial Setup

After you install the software, a new database will be automatically setup for you to begin using.  So, basically there is no real setup section to worry about.  You can begin using the software right away.

4. Upgrading

5. Operations

5.1. Databases

Location

To change where your database files are stored, run the program. Click Database then Move Location.  

This will open the Select Directory window

Here you select where you would like to store your database files. After setting the location, click OK. All of your database files will be moved to the new location and Black Hole Organizer will then point to that directory.

If you have BHO set up as the Portable Edition, you can only change the folder where the data is stored, you cannot change the drive.

Multiple

The fully licensed version allows you to keep your data in multiple databases. To create a new database, click File then New Database.

This will open the Create Database window.

Type in the name of the new database you wish to create. Click OK and the new data files will be created automatically.

To open an existing database, click File then Open Database. Type in the name of the database you wish to open..

If you enable the Database Toolbar you can also select a valid table from the list displayed. To enable/disable this toolbar, click View then Toolbars then click on Database to either enable or disable.

Packing

If you delete records from your database you will notice that the data file does not actually decrease in size. We will reuse these empty records on the fly as needed. If you would like to pack your database to remove any empty record placeholders you may do so by choosing the Pack option from the Database menu. Click Database then Pack Database.

Password

You may password protect your database so that others may not access it from within Black Hole Organizer. To do this click Database then Password Protect.

This will open the Password Protect window.

If you have an existing password and would like to change it you must enter the old password in order to allow the change to take place. This will prevent someone else from coming along and changing your password while you are not around!

If you have a password and would like to remove it simply enter the old password in the first field and leave the new password fields blank. This will remove the password protection from the database.

When you are finished, click OK.

5.2. Custom Columns

You can add Customized Columns to Black Hole Organizer and name it/them anything you wish.

Adding a Field

To add a filed, click on Database then Customize then New Column.

This will open the New user defined field dialog box.

Here you have the Field Name & Type.

Field Name: 
Enter the name you want to use for this field/column.

Field Type: 
You can specify which type of field you want to use. Selecting Options allows you to define a preset values that can go into this field.

Option Values: 
Specifies predefined values that will be used for this field.

After you have named the field and selected the Type, click OK.

Your new Column is now there.

Deleting a Field:
You can delete the field you created. Click on Database then Customize then Delete Column.

You will be presented with a list of Columns that you created. Simply select which column you wish to delete.

The column will be removed.

Updating Values

There are two ways to edit a custom field. The first is to right click on the document list and choose the Custom Fields option and then select the field you want to modify.

Once selected a dialog box will appear allowing you to enter the necessary value. The dialog box will be based on the Type that was defined when you created the column.

The second way is to put your mouse over the field you want to edit and press F2. An edit field will appear allowing you to make the changes on the screen itself.

5.3. Documents

Each category can have its own list of documents.

Drag and Drop

Black Hole Organizer fully supports drag and drop. You may drag any text to either the Floater or the main application.
In the main program, if you drop text onto the memopad the text will be inserted into the existing document. If you drop it onto the category list a new document will be created with the dropped text.
Dragging files to the document list or the category list will insert selected documents using the original filename as the document name. If a document already exists then an incremented number will be used. For example, if "readme.txt" file exists as a document name then the new file will become "readme.txt 1" or "readme.txt 2" until a unique name can be found.
Documents can be moved from one category to another by dragging them from the list and dropping them onto a new category.

Clipboard

For applications that do not support drag and drop you may wish to utilize the clipboard for transferring data to Black Hole. You can define a system level keystroke under the Options dialog. When invoked Black Hole Organizer will restore itself from a minimized state and open the document importer dialog and place the contents of the clipboard in the memo pad. You can then select a category and document name and click OK.
You can then resume whatever task you were working on previously.
If you are in the document manager you can invoke the clipboard by pressing Ctrl+Shift+V.

Document Importer

When you drag text into the Floater or the Main program, the Document Importer dialog window will appear and your copied information will be entered into the text area. 

It gives you the opportunity to modify it, give it a name and select the category it should be placed in. Also when you choose to create a document from the clipboard from one of the popup menus or using the hotkey it will appear in this window.

Exporting

You can export all of the documents in a selected category by right clicking on the category. Select the Export option then select a folder to save the documents to. By default all files are saved as RTF documents. A prompt will appear asking if you would like to save them as plain TXT files.
If you only want to export a single document you need to right click on the document in the document list and choose the Save document as option. Change extension from .rft to .txt before clicking the save button and the document will be saved as a plain text file. Otherwise it will be saved as an RTF file.

Emailing

You can email documents directly from Black Hole. In fact, there are two options that allow you to do this. The first requires you to have a MAPI compliant email client installed on your system. If this is not installed the MAPI option in Black Hole should be disabled. The other is to mail selected documents out using Black Hole's built-in email client.
Simply select the documents you would like to email and select the Send to menu option under the Database|Documents menu or the popup menu for the document listing. Then choose the method in which you wish to email your documents.
Selecting the MAPI method will open your own email client with a new message and fill in the contents with your selected document. You can then choose the recipient from your own address book.
Selecting the Internal E-Mail client will open a new message box. You then type in the address of the person you wish to send the message to. If you click on the button that says To: then Black Hole's address book will appear and you can check off the names you wish to send to. Watch the status bar, when it says that it is done you can close the box up.
Many hosts require you to log in before sending an email message, otherwise you may get a Relaying is prohibited error. To avoid this simply enter the user id and password in the email settings screen. At a minimum you must enter a server name to log into and your reply-to address.

Deleting

Documents can be deleted either permanently or sent to your system's recycle bin. To Delete a Document, select it from the Document window then select Delete.

To toggle the recycle bin option click on Tools then General Options or Ctrl+G.

This will display the General Options dialog box. Select the Actions tab then toggle Delete to Recycle Bin to your liking.

After you have made your selection, click OK.


5.4. Floater

The 'Floater' is a visual box that stays on top of your desktop. You can drag/drop items to it for quick storage. It will also pop up your reminders as well as give you access to your stored links and email addresses. There are two ways you can minimize to the Floater. You can toggle Black Hole Organizer to the Floater view by clicking View then Minimize to Floater.

You can also click the As Floater button on the main Toolbar. To do so, click As Floater.

The Floater will then appear on your desktop.

By right clicking the floater you can restore it back to the manager window. Douple clicking will also restore.

You can copy information off of Web pages and easily put it into Black Hole. If you have copied text to the clipboard just put your mouse cursor over the 'hole', right-click, and you can make a document from the material in the clipboard.

You can select what folder the information will go in. If you are using and application that supports Drag and Drop, like Internet Explorer, you can simply drag your information from it over to the Black Hole and the Document Importer dialog box will open so that you can create a new document from the dragged text.

You can change the default image used in the Floater. First, find an image you wish to use. Right Click on it and select Copy. This puts it on your Clipboard (not visible). From the Tools menu you can select Capture image for floater.

This screen will appear with what you copied to the Clipboard

Click OK and this image will then automatically be assigned to your floater.

This Floater box can be resized if you want it to be larger. To do so, place your pointer onto an edge or corner of the box, the double sided arrow will appear, then left click and drag to desired size.

Black Hole Organizer will not edit the picture for you but you can load your favorite graphics package and modify as desired.

5.5. Reminders / Alarms

After you have created a document, you can set up Black Hole Organizer to remind you to go back to the document to perform any task that may be needed or followed up on. To do this, highlight the document you wish to set up a reminder alarm for and right click then select Set Reminder.

When you choose to set a reminder alarm for a particular document this window will appear.

Click on the date and enter the time you wish to be reminded to look at this document.

For any reminder/alarm to be recognized you must check on the Monitor Document Reminders menu option. Click on Tools then Monitor Document Reminders.

If it is not enabled you will be prompted to turn this on when you set an alarm.

DOCUMENT REMINDER

When the above document reminder pops up you will see all the documents that have been set up with reminders for that time period. If you do not clear a document reminder setting it will continue to appear. You can double click on a listing in the reminder window to take Black Hole Organizer directly to the document. This can be done for each document in the list. When you are done click the close button.

If you are busy when the reminder window appears but want to be reminded again soon you can hit the Snooze button. Set the number of minutes to what you need so that you can be reminded at a better time.

5.6. Spell Checker

A spell checker is also included. Using LiveSpell you can see the words that you need to correct instantly as they will have a red squiggle line below them.

CORRECTED SPELLING

Right click on a misspelled word and you will be presented with a list of possible correctly spelled words.

SPELLING OPTIONS

To access the Spelling Options screen, click on Tools then Spell Check Options.

Specify the options you want to use with the spell checker here.

When you are finished making your selections, click OK.

 

To add other Dictionaries to the software just do the following:

You can obtain other dictionaries from here:
http://www.addictivesoftware.com/addict3/dicts.htm

Just save the ones you need and unzip them into a folder of your choice or to here: C:\Program Files (x86)\BlackHole (if using W7 64bit) or C:\Program Files\BlackHole if not 64 bit.

Then in the program, just click on the Tools menu, then Spell Check Options. In the Dictionaries section, click on the locate Dictionaries and it will prompt you to browse to the folder that you stored the dictionaries in. Just select them and they will be added to the programs options.

5.7. Power Searching

Power Search allows you to quickly search all of your documents for a particular text. See below to use the options available.

MAIN AREA

To access the Power Search dialog screen, click on Search then Power Search or Shift+Ctrl+F.

To perform a simple search, enter the text in the Locate field and click the Find Now button. To narrow your search parameters, use the Text and Date options available on their respective tabs.

OPTIONS

  • Text Options tab
  • Date Options tab 

Selecting either of these options allows you to refine your search.

WORDS TO LOCATE

Simply type in the text you wish to search for.

DATABASE CATEGORIES

To search a specific category select it here. Press CTRL when clicking on a selected category to deselect it.

SEARCH RESULTS


6. How Do I...

6.1. Backup the Data Files

Access the backup dialog from the File|Backup/Restore menu. Select the databases you wish to backup as well as any password you would like to use to protect your backup. Backup files will always use a .bzp extension, these files are Zip compatible but so that we can differentiate between other zip files and our backups we use this extension. Select the overwrite method you wish to use here as well. If a file that you are backing up already exists in the archive file and it has not changed it will not save it again.

Run the program. Click File, then Backup/Restore then Backup Database.

This will open the Data Backup window.

On this screen you have 4 options to choose from:

  1. Specify Location - Specify the file you want to save your data into. There will be a default location already listed here. You can just use that. The file location by default is C:\Users\USER NAME\Documents\Black Hole Organizer\data\blackhole_data_backup.bzp
  2. Overwrite Options - How would you like to have existing files overwritten? Yes will automatically overwrite. No will skip. Prompt will ask you if you want to overwrite the data.
  3. Password - Your data can be password protected if you like. Enter the password in the two fields. Keying in your password in the two fields ensures you typed what you thought you had.
  4. Database List - Select the databases that you would like to include in this backup.

Once you have made your selection, click OK and your database will be backed up.
 

6.2. Restore the Data Files

Access the restore dialog from the File|Backup/Restore menu. Select the databases you wish to restore as well as the overwrite method to use. If you password protected your archive you will be prompted for the password during the restore process. The restore dialog always defaults to the last backup archive you saved to as well as the current data directory.

Run the program. Click File then Backup/Restore then Restore Database

This will open the Import/Restore window

On this screen you have 5 options to choose from:

  1. Restore From - Backup data file you want to restore your data from. By default, the location will be the save to location when the backup was performed.
  2. Restore To - Where do you want to restore your data to? By default, this will be where the data resides after installation.
  3. Overwrite Options - Specify how you want any existing files to be handled when extracting backup data. Prompt is the default. It will ask what you would like to do once you select OK. 
  4. Databases - A list of databases that are in this backup file. It is possible you will have only one. You may have more if you have more than one database set up.
  5. Restore Which File -Which databases to restore, either the ones that are selected or all of the ones in the list. Select an individual database file if you have multiple.

Once you have made your selctions, click OK. Your backep up/saved database will be restored. 


6.3. Check for Updates

At anytime, you can check to see if there are any Updates/Upgrades available for this product.
To perform this task, just run the program.  Click on the Help menu from the main screen, then click on Check for Updates.

This will tell the program to check our web site for any available Upgrades/Updates.  If one is available, it will prompt you that there is an update available and ask you if you wish to download and install it.  If you choose to do so, just follow the prompts that come up.  Your system will then ask you to restart the program, which will run the installation of the Updates/Upgrade.  Just select the defaults and you should be good to go and the new version will be installed.

All Updates/Upgrades are available at no charge for a period of One (1) year from the original date of purchase.  Unless you are current on our Support/Upgrades/Updates licensing, I would not suggest upgrading or updating, as you may need to purchase the upgrade/update.

If the update is for the same Major Version, such as 3.20 and you already purchase a version 3.xx version, you will not need to purchase the upgrade.  Only when it upgrades to say version 4.xx, as the major version number changed.  As your original registration codes are valid though the full major version cycle.

7. FAQ's

7.1. Can I create multiple databases?

Yes, this is a major part of the program.  You can just run the software, click on the File menu, then click on New Database.  This will prompt you to give the new database a name.  After filling out the name, just click OK.  A new database is created and can be selected at anytime by using the File menu, Open command, or even easier, just select the drop down box near the top right of the screen, it will list all the databases you have created.

7.2. Do you have a PDF of the Help Text for Black Hole Organizer?

Yes, you can obtain it here.

Black Hole Organizer Help Text PDF

8. Error Messages

9. Upgrades

9.1. Free Upgrades/Updates for a period of one year from Purchase date.

All of our software comes with a full year of support and free upgrades/updates.  This is based on the purchase date of the software.  If you are unsure of the date of purchase and wonder if you are eligible for a free upgrade/update, just contact us via our help desk with your information and we will respond with the answer.

10. System Requirements

10.1. System Requirements

Microsoft Windows XP/Vista, 7, & 8 operating system.

Minimum 10 MB of free hard disk space

CD-ROM drive to install from CD

133 MHz processor or higher

32 MB of memory or higher

VGA or higher monitor resolution displayed at 640x480 pixels minimum and at least a minimum of 256 colors.

Windows-compatible modem required for download of program if not purchased on CD

10.2. EULA - End User License Agreement

End User License Agreement for Starre Enterprises Software

This EULA is a legal agreement between you (either an individual or a single entity) and Starre Enterprises for the Starre Enterprises Software accompanying this EULA, which includes the accompanying computer software, and may include associated media, printed materials and any "online" or electronic documentation ("SOFTWARE"). By installing the SOFTWARE, you agree to be bound by the terms of this EULA. If you do not agree to the terms of this EULA, you may not install or use the SOFTWARE.

SOFTWARE PRODUCT LICENSE

The SOFTWARE is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The SOFTWARE is licensed, not sold.

1. GRANT OF LICENSE. This EULA grants you the following rights:

Software. You may install, use, access, display, run, or otherwise interact with ("RUN") one copy of the SOFTWARE, on a single computer, workstation, terminal, hand held PC, pager, "smart phone," or other digital electronic device ("COMPUTER"). The primary user of the COMPUTER on which the SOFTWARE is installed may make a second copy for his or her exclusive use on a portable computer.

Storage/Network Use. You may also store or install a copy of the SOFTWARE on a storage device, such as a network server, used only to RUN the SOFTWARE on your other COMPUTERS over an internal network; however, you must acquire and dedicate a license for each separate COMPUTER on which the SOFTWARE is RUN from the storage device. A license for the SOFTWARE may not be shared or used concurrently on different COMPUTERS.

Reservation of Rights. All rights not expressly granted are reserved by Starre Enterprises.

Accessing Services Using the SOFTWARE. Your use of any service accessible using the SOFTWARE is not covered by this EULA and may be governed by separate terms of use, conditions or notices.

2. RESTRICTIONS.

You must maintain all copyright notices on all copies of the SOFTWARE.

Limitations of Reverse Engineering, De compilation and Disassembly. You may not reverse engineer, decompile, or disassemble the SOFTWARE, except and only to the extent that such activity is permitted by applicable law notwithstanding this limitation.

Rental. You may not rent or lease or lend the SOFTWARE.

Software Transfer. You may permanently transfer all of your rights under this EULA one time, provided you retain no copies, you transfer all of the SOFTWARE (including all component parts, the media and printed materials, any upgrades, this EULA and, if applicable, the Certificate of Authenticity), you do not receive any payment or other compensation for transferring the SOFTWARE and the recipient agrees to the terms of this EULA. If the SOFTWARE portion is an upgrade, any transfer must include all prior versions of the SOFTWARE.

Support Services. Starre Enterprises may provide you with support services related to the SOFTWARE ("Support Services"), in its discretion. Use of Support Services, if any, is governed by the Starre Enterprises policies and programs described in the user manual, in "online" documentation, and/or other Starre Enterprises-provided materials. Any supplemental software code provided to you as a part of Support Services shall be considered part of the SOFTWARE and subject to the terms of this EULA. With respect to technical information you provide to Starre Enterprises as part of the Support Services, Starre Enterprises may use such information for its business purposes, including for product support and development. Starre Enterprises will not utilize such technical information in a form that personally identifies you except to the extent necessary to provide you with support.

Replacement, Modification and Upgrade of the Software. Starre Enterprises reserves the right to replace, modify or upgrade the SOFTWARE at any time by offering you a replacement or modified version of the SOFTWARE or such upgrade and to charge for such replacement, modification or upgrade. Any such replacement or modified software code or upgrade to the SOFTWARE offered to you by Starre Enterprises shall be considered part of the SOFTWARE and subject to the terms of this EULA (unless this EULA is superseded by a further EULA accompanying such replacement or modified version of or upgrade to the SOFTWARE). In the event that Starre Enterprises offers a replacement or modified version of or any upgrade to the SOFTWARE, (a) your continued use of the SOFTWARE is conditioned on your acceptance of such replacement or modified version of or upgrade to the SOFTWARE and any accompanying superseding EULA and (b) in the case of the replacement or modified SOFTWARE, your use of all prior versions of the SOFTWARE is terminated.

3. TERMINATION. Without prejudice to any other rights, Starre Enterprises may terminate this EULA if you fail to comply with the terms and conditions of this EULA. Starre Enterprises may terminate this EULA by offering you a superseding EULA for the SOFTWARE or any replacement or modified version of or upgrade to the SOFTWARE and conditioning your continued use of the SOFTWARE or such replacement, modified or upgraded version on your acceptance of such superseding EULA. In addition, Starre Enterprises may terminate this EULA by notifying you that your continued use of the SOFTWARE is prohibited. In the event that Starre Enterprises terminates this EULA, you must immediately stop using the SOFTWARE and destroy all copies of the SOFTWARE and all of its component parts.

4. COPYRIGHT. All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animations, video, audio, music, text and "," incorporated into the SOFTWARE), the accompanying printed materials, and any copies of the SOFTWARE, are owned by Starre Enterprises or its suppliers. All title and intellectual property rights in and to the content which may be accessed through use of the SOFTWARE is the property of the respective content owner and may be protected by applicable copyright or other intellectual property laws and treaties. This EULA grants you no rights to use such content. If this SOFTWARE contains documentation which is provided only in electronic form, you may print one copy of such electronic documentation. You may not copy the printed materials accompanying the SOFTWARE.

5. EXPORT RESTRICTIONS. You agree that you will not export or re-export the SOFTWARE, any part thereof, or any process or service that is the direct product of the SOFTWARE (the foregoing collectively referred to as the "Restricted Components"), to any country, person or entity subject to U.S. export restrictions. You specifically agree not to export or re-export any of the Restricted Components (i) to any country to which the U.S. has embargoed or restricted the export of goods or services, which currently include, but are not necessarily limited to Cuba, Iran, Iraq, Libya, North Korea, Sudan and Syria, or to any national of any such country, wherever located, who intends to transmit or transport the Restricted Components back to such country; (ii) to any person or entity who you know or have reason to know will utilize the Restricted Components in the design, development or production of nuclear, chemical or biological weapons; or (iii) to any person or entity who has been prohibited from participating in U.S. export transactions by any federal agency of the U.S. government. You warrant and represent that neither the U.S. Commerce Department, Bureau of Export Administration nor any other U.S. federal agency has suspended, revoked or denied your export privileges.

6. DISCLAIMER OF WARRANTIES. Starre Enterprises AND ITS SUPPLIERS PROVIDE THE SOFTWARE "AS IS" AND WITH ALL FAULTS, AND HEREBY DISCLAIM ALL OTHER WARRANTIES AND CONDITIONS, EITHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO ANY (IF ANY) IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, OF FITNESS FOR A PARTICULAR PURPOSE, OF LACK OF VIRUSES, AND OF LACK OF NEGLIGENCE OR LACK OF WORKMANLIKE EFFORT. ALSO, THERE IS NO WARRANTY OR CONDITION OF TITLE, OF QUIET ENJOYMENT, OR OF NONINFRINGEMENT. THE ENTIRE RISK ARISING OUT OF THE USE OR PERFORMANCE OF THE SOFTWARE IS WITH YOU.

7. EXCLUSION OF ALL DAMAGES. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL Starre Enterprises OR ITS SUPPLIERS BE LIABLE FOR ANY CONSEQUENTIAL, INCIDENTAL, DIRECT, INDIRECT, SPECIAL, PUNITIVE, OR OTHER DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR ANY INJURY TO PERSON OR PROPERTY, DAMAGES FOR LOSS OF PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, FOR LOSS OF PRIVACY FOR FAILURE TO MEET ANY DUTY INCLUDING OF GOOD FAITH OR OF REASONABLE CARE, FOR NEGLIGENCE, AND FOR ANY PECUNIARY OR OTHER LOSS WHATSOEVER) ARISING OUT OF OR IN ANY WAY RELATED TO THE USE OF OR INABILITY TO USE THE SOFTWARE, WHETHER BASED ON CONTRACT, TORT, NEGLIGENCE, STRICT LIABILITY OR OTHERWISE, EVEN IF Starre Enterprises OR ANY SUPPLIER HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THIS EXCLUSION OF DAMAGES SHALL BE EFFECTIVE EVEN IF ANY REMEDY FAILS OF ITS ESSENTIAL PURPOSE.

8. LIMITATION AND RELEASE OF LIABILITY. Starre Enterprises has included in this EULA terms that disclaim all warranties and liability for the SOFTWARE. To the full extent allowed by law, YOU HEREBY RELEASE Starre Enterprises AND ITS SUPPLIERS FROM ANY AND ALL LIABILITY ARISING FROM OR RELATED TO ALL CLAIMS CONCERNING THE SOFTWARE OR ITS USE. If you do not wish to accept the SOFTWARE under the terms of this EULA, do not install the SOFTWARE.

9. GOVERNING LAW. If you acquired the SOFTWARE in the United States of America, the laws of the State of North Carolina, U.S.A will apply to this contract. If you acquired this SOFTWARE outside of the United States of America, then local law may apply. 

11. Registration/Purchasing

11.1. Registration/Purchasing

This product is being marketed as Try Before You Buy software. (Cost is only $24.95 USD)

You can use this version of Black Hole Organizer to evaluate it and to see if it suits your needs.  If you wish to continue to use it, then you must register it.  Registration is easy and inexpensive.  Registration costs US$24.95, and gets you unlimited use, all upgrades/updates, along with free email support for up to a year.

By Cash or Check

You can order with Cash, Money Order, or Check drawn on a US bank.

To place your order, please fill out and print the registration form. This can be found from the Help menu, just click on Print Registration Form.  Enclose this form and please send Cash, Money Order, or Check to:

Starre Enterprises, Inc.
P.O. Box 1075
Mocksville, NC  27028

By Credit Card

You can also register by going to www.starresoft.com/bhopurchase.htm on the internet.

Here you will find the instructions to pay by credit card.

After receiving funds, you will be emailed the registration codes. If you do not have an email account, please include a mailing address. We will send it snail mail.

Be sure to include the following with your submission:

Name

Address and/or email address

Version of software

Where the software was obtained

Thank you for supporting our software.

After purchasing the software, you will be either e-mailed and/or mailed to you a code that needs to be entered into the software to unlock it. If you already are receiving a message to register, all you have to do is to click on the button which will display which codes to enter into the system. If you are not receiving this message yet, and would like to key in your registration codes you can select the Program menu option to register.  Click on Start, All Programs, Black Hole Organizer, Utilities, and click on Register Program.  Then key in the registration codes that were sent to you. This will unlock the program for full usage.

11.2. How To Enter Registration Code

Once you receive the e-mail which contains your registration codes, you can enter them by clicking the Windows start button, then click All Programs, select Black Hole Organizer, then Utilities and click on Register Program. 

A dialog box will appear and simply enter the name and key into the fields.

You must enter the information exactly as they appear on the e-mail you received.
After you have filled in the fields, click OK.

Your program is now registered. 


12. Version History

12.1. Version History

There is a web page setup with the version history of this product.  Here is the link.

http://www.starresoft.com/bhohistory.htm