HomeStar Bill of LadingOperationsCustom Reports

6.1. Custom Reports

This section will explain how to use the Custom Reports section of the program.

This section is available as an add in to the program.  It is available via our web site at: http://www.starbol.com

To access this section in the program, you just need to select the Reports menu from the main screen, then select the menu options Custom Reports. 
This menu option will only be displayed and accessible if you have purchased and installed the Custom Reports Module. 

This will display the following screen.

There are multiple options you can select from this screen to start with.

The menu options at the top of the screen can be used and contain the following commands.

File Menu:

Open

New

Design

Print

Print Preview

Delete

Rename

Close

These options are used to create a new Folder, or Report and proceed from there.

You can also use the right click option on your mouse to bring up these options on the screen.

To start, just click on the File menu, then click on the New option, then select Folder.  

This will allow you to create a new folder in the system to store your custom reports in.  You can name it anything you wish, just use something that makes sense to you.
We will call our example Report 1

Then select that folder and click on the File menu again or right click, whichever you prefer and select New Report.

This will bring up the Report Designer as displayed.

There are three tabs on the top of the screen.  Data, Design, and Preview. 

You begin by selecting the Data tab.  This is where you would select the data that is to be used in the report.  You just click on the tab for Data.  You will be displayed a blank screen unless you already created the data specs. Here you would just click on the File menu, then New.  This will display the New Items.  Just click on the Query Wizard then click on OK, to begin the data selection process.

After selecting the Query Wizard, you will be displayed this screen to select the table to be used..

Here is a list of the available tables to be used..

BOLD - Bill of Lading Detail file.

BOLH - Bill of Lading Header file.

CARR - Carrier file

CLAS - Classifications file

CONS - Consignee file

CTRL - Control/Shipper file.

DELT - Deliver to file

DESC - Descriptions/Items file

All the other files listed are really not available for reporting, but are in the database and won't mean anything to the end user.

To select a file, just dbl-click on it or highlight it and click on the > arrow button to load into the selected tables section.

For example, select the CONS file.

Then click on the Next button.

There are other options to allow for customizing things, but you can just continue until you get to the Order screen.  This will allow you to select the order the file will be presented or sorted.  Just click on the Set Order and select a field such as the Consignee Name and click Continue.

You will then be displayed the finished screen.  Just click the Finish button.

You will be brought back to the Designer screen.

You have now selected a table to be used in creating the report.

From here just click on the Design Tab and you will be displayed the report designer.

You have different areas that you can perform functions with.

Report Tree - This shows the different sections of the report

Report Bands - This shows the different bands in creating the report layout.

Selection Properties - This shows the available properties for the selected item.

Available Table Fields - These are the available table fields to place on the report.

You can select a table field and place or drag right from the Available Table fields.  When you select a field and drag it to the Detail band, it will automatically select the field to be printed along with a header or text field to describe it.  You can change the header field or just delete it if not needed by selecting it and pressing the delete key.  To change it just change the text in the text selection field as shown.

After adding fields and whatever you wish to change, you can click on the Preview button to see the results of the report.

If all is well, then just click on the File menu on the Design Tab and select Save.  This will prompt you for a name to save the report as.

After you save it, just close the Design screen and it will be displayed on the Report Explorer screen.

You have created your first report.

You can select the report again and either print it, preview, go back again and edit it, delete it, etc.

You can create as many reports as you wish and organize them in the Report Explorer.

For more details, on usage, just contact our help desk located at http://help.starre.com

 

This page was: Helpful | Not Helpful